FreeBSD.se / 2200 registrerade användare / på webben sedan 2002-03-09 / Home
Search   
Contribute | Calendar | Advanced Search | Site Statistics | Directory | installationsguide | Forum | Filarkiv | FAQ's | Web Resources | Polls |
 Welcome to FreeBSD.seWednesday, April 23 2014 @ 06:38 PM CEST 
Forum Menu
Forum Index
Site Members
Popular Topics

Sektioner
Home
Lathundar (71/0)
Säkerhet (194/0)
Små Tips (22/0)
Artiklar (81/0)
Intervjuer (4/0)
Nyheter (202/0)
Tävlingar (7/0)

Händelser
There are no upcoming events

User Functions
:

:


Lost your password?

Reklam



Vem är online
Guest Users: 3

Sponsorer







 Forum Index > Support > Support New Topic Post Reply
 Tangentbords meck..
 |  Printable Version
zealot
 November 08 2003 00:22 AM (Read 9591 times)  
Forum Newbie
Newbie

Status: offline

Registered: 10/26/03
Posts: 5

Installerade FreeBSD för ett litet tag sedan, slängde ut min kära gamla Slackware-installation.. Allt har gått fin-fint förutom en sak, har problem med mina tangentbords inställningar.

Det som stör mig, eller som gör X-Windows ganska oanvändbart, är att jag i en xterm (aterm, Eterm har provat dessa) inte kan använda pipe. Kan inte skriva den symbolen alltså, inte heller > eller


 
Profile Email
Quote
Anonymous: 32x
 November 08 2003 12:49 PM  


Option \"XkbRules\" \"xfree86\"
Option \"XkbModel\" \"pc105\"
Option \"XkbLayout\" \"se\"

byt till

Option \"XkbRules\" \"xfree86\"
Option \"XkbModel\" \"pc102\"
Option \"XkbLayout\" \"se\"


 
Quote
zealot
 November 08 2003 20:13 PM  
Forum Newbie
Newbie

Status: offline

Registered: 10/26/03
Posts: 5

Quote by 32x:
byt till

Option \"XkbRules\" \"xfree86\"
Option \"XkbModel\" \"pc102\"
Option \"XkbLayout\" \"se\"


Har provat det nu, fungerar fortfarande inte..
Det är ingen speciell modul man behöver till XFree86, eller font kanske?

Håller på att cvsup:a till 4.X nu, hoppas att det kan lösa problemet.


 
Profile Email
Quote
Anonymous: 32x
 November 09 2003 19:09 PM  


hmm..jag hade iaf samma problem..\"pipe\"-tangenten fungerade inte...och det jag skrev ovan lösten problemet för mig iaf.


 
Quote
freekow
 November 09 2003 19:15 PM  
Forum Newbie
Newbie

Status: offline

Registered: 11/08/03
Posts: 3

Jag har med haft samma problem men för mig funkar det med
\'Option \"XkbModel\" \"pc103\"\' varför vet jag inte, men jag satt bara och laborerade mig fram.


"Only two things are infinite, the universe and human stupidity, and I´m not sure about the former." - Albert Einstein (1879-1955)
 
Profile Email
Quote
phryx
 November 10 2003 00:21 AM  
Forum Newbie
Newbie

Status: offline

Registered: 06/05/02
Posts: 8

kör XFree86-4.3.0,1 och kan säja att pc102 inte funkar och då har jag ett rätt så standard tangentbord.

men om det är någon som kommer på en universal lösning så v.g. och posta den här. Smile


 
Profile Email Website
Quote
zealot
 November 11 2003 07:47 AM  
Forum Newbie
Newbie

Status: offline

Registered: 10/26/03
Posts: 5

Så, har provat alla pc10x-lösningar, utan lyckat resultat..

Får väl ta och testa alla andra möjliga modeller, se om någon kanske funka. Låter er veta isf.

Tack för alla tips!


 
Profile Email
Quote
Anonymous: orange
 December 27 2003 01:22 AM  


Jag har precis samma problem som beskrevs i det ursprungliga inlägget. Har du fått rätt på det? Hur? Tacksam för svar...


 
Quote
tubbs
 April 01 2004 22:56 PM  
Forum Admin
Admin

Status: offline

Registered: 03/07/02
Posts: 233

Jag löste detta problem genom att editera

/usr/X11R6/lib/X11/xkb/symbols/pc/se

Under sektionen som börjar med xkb_symbols la jag till raden

 key <LSGT>  { [      less,    greater,          bar,    brokenbar ] };



 
Profile Email Website
Quote
zealot
 April 10 2004 11:12 AM  
Forum Newbie
Newbie

Status: offline

Registered: 10/26/03
Posts: 5

Har nu äntligen sett en lösning på problemet, efter ett tips jag fick via email från Antonios.

Han har en bärbar Latitude där han hade det här problemet med pipe-tangenten. I `xf86cfg' så valde han `Inspiron' som tangentbords-layout, och svenska förstås. Och det funkade för honom.

Provade att göra samma sak, och det funkade för mig, så nu är allt frid och fröjd!


 
Profile Email
Quote
Malcolm
 August 25 2004 10:50 AM  


Status: offline

Registered: 05/26/04
Posts: 42

...eftersom FreeBSD 5.3 har bytt till X.org så antar jag att den här tråden vaknar till liv igen

Efter lite pillande och googlande så funkar det för mig.
Sektionen i min xorg.conf för tangentbordet ser ut såhär:

Section "InputDevice"
	Identifier	"Keyboard0"
	Driver  	"keyboard"
	Option	"XkbRules"	"xorg"
	Option	"XkbModel"	"pc105"
	Option	"XkbLayout"	"sv_SE"
EndSection


 
Profile Email
Quote
gatan
 May 15 2005 17:32 PM  
Forum Newbie
Newbie

Status: offline

Registered: 05/11/05
Posts: 5

Malcom
Det funkar fortfarande inte for mig...men ar som sagt newb, har aven kollat att jag har swe.iso med ocksa :/


 
Profile Email
Quote
Malcolm
 May 15 2005 20:36 PM  


Status: offline

Registered: 05/26/04
Posts: 42

Nah, den där configgen verkar bara ha funkat ett tag. Det var precis när Xorg dök upp i FreeBSD istället för XFree86.

För närvarande kör jag inga installningar för sådant i /etc/X11/xorg.conf utan låter varje användare själv bestämma vad de vill ha för tangentbord i Gnome...

Ur min /etc/X11/xorg.conf

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection



 
Profile Email
Quote
gatan
 May 16 2005 05:35 AM  
Forum Newbie
Newbie

Status: offline

Registered: 05/11/05
Posts: 5

Min:

Option "XkbRules" "xorg"
Option "XkbModel" "102 testar 105 ocksa"
Option "XkbLayout" "se"

Har testat manga olika som jag har sett er skriva har pa forumet, ingen har dme har funkat :/ Nagon som kan vara snall och visa vad man ska ha i xorg for att fixa "aao"

Svenskt tangentbord funkar fint i webläsaren osv, men inte i shell. Vad beror det på?


 
Profile Email
Quote
Nixx
 May 16 2005 14:40 PM  
Forum Admin
Admin

Status: offline

Registered: 03/10/02
Posts: 1412

Läs först: http://www.freebsd.se/faqman/index.php?op=view&t=6

Här är relevant del ur min xorg.conf:

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "se"
Option "XkbModel" "pc105"
EndSection

Om du fortfarande har problem med åä och ö efter detta har du förmodligen gjort något fel. Om du däremot har problem med

| < > 

kan du bli tvungen att följa hur tubbs löste det. (Samma tråd som denna, högre upp).


"Any society that would give up a little liberty to gain a little security will deserve neither and lose both." - Benjamin Franklin
 
Profile Email Website
Quote
Anonymous: anonymous
 June 03 2005 17:19 PM  


Hej, ett litet problem som jag tänkte kunde passa denssa tråd. Jag fick problem med åäö när jag installerade aterm, någon som upplevt samma sak? Jag kör aterm med "-fn fixed" flaggan eftersom jag tänkte att det funkade så i xterm. Jag provade även -fb fixed och -fm fixed, men inget gav åäö i t.ex. vi eller irssi


 
Quote
Malcolm
 December 04 2005 18:34 PM  


Status: offline

Registered: 05/26/04
Posts: 42

Suck. Den här tråden kommer aldrig att ta slut.

I och med uppgraderingen av Gnome till 2.12.2 slutade mitt tangentbord att fungera korrekt. Det har uppmärksammats på FreeBSD-Gnome-listan, och det kommer väl en lösning vad det lider. Efter pill funkar mitt tangentbord igen. Såhär gjorde jag:

i /etc/X11/xorg.conf ändrade jag i tangentbordsdelen till:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option  "XkbLayout"     "se"
EndSection


och i gnomes "Configuration Editor" ändrade jag i
/desktop/gnome/peripherals/keyboard/kbd
där jag hittade en ruta för "overrideSettings". Den kryssade jag ur och startade sedan om X. Vips fick jag tillbaka de förlorade tecknen.

Den som uppgraderat finner vid "overrideSettings" en lagom kryptisk text:

"Very soon, keyboard settings in gconf will be overridden (from the system configuration) This key has been deprecated since GNOME 2.12, please unset the model, layouts and options keys to get the default system configuration."

Jag förstår ju vad som står, men jag begriper inte rikigt varför...


 
Profile Email
Quote
Malcolm
 December 07 2005 21:46 PM  


Status: offline

Registered: 05/26/04
Posts: 42

Min föregående post verkar ha varit resultat av en liten bugg i libxklavier. Uppdatering på gång.


 
Profile Email
Quote
Content generated in: 0.61 seconds
New Topic Post Reply



 All times are CEST. The time is now 06:38 PM.

Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
Filtered HTML Allowed 
Censored Content